Drag race turbo 400 diagnosis

Transmission to Rear-end

Moderator: Team

Post Reply
Ron Gusack
Expert
Expert
Posts: 684
Joined: Sat Dec 22, 2007 11:42 pm
Location: Maryland

Drag race turbo 400 diagnosis

Post by Ron Gusack » Mon Oct 08, 2018 12:25 pm

I turn off the track to get onto the return road and the car stops like I stepped on the brake pedal kinda hard. The engine is running but the car won't move. It acts like I'm power braking it or like it has a trans brake, which it doesn't. I cut it off and sit there for a few seconds, restart it and it moves, drive it back down the return road and as soon as I get into the pit area it stops and won't move. I shut it off, look under the car and see nothing obvious. Stick it in neutral and coast to the back of the trailer. Start it up and drive it up on the trailer too far, put it in reverse and it won't move but this is like it's in neutral. What's the diagnosis based on these symptoms.
Trans temp was 155 leaving the line and got as high as 169 before I cut it off. I didn't hear any weird noises. Footbrake car with 251 runs on trans with spragless converter and 82 runs on the type F fluid and filter.
The things you see when you ain't got your gun!

lefty o
Guru
Guru
Posts: 1349
Joined: Tue Oct 15, 2013 8:50 am

Re: Drag race turbo 400 diagnosis

Post by lefty o » Tue Oct 09, 2018 12:59 pm

im no trans guy, but sounds like something hanging up in the valve body.

6.50camaro
Member
Member
Posts: 112
Joined: Sun Jul 30, 2017 2:24 pm
Location: DeRidder, La

Re: Drag race turbo 400 diagnosis

Post by 6.50camaro » Tue Oct 09, 2018 5:16 pm

No expert either,Sounds like something is hanging up the intermedient band. Dan

6.50camaro
Member
Member
Posts: 112
Joined: Sun Jul 30, 2017 2:24 pm
Location: DeRidder, La

Re: Drag race turbo 400 diagnosis

Post by 6.50camaro » Tue Oct 09, 2018 6:51 pm

Like I said not an expert I ment the low reverse band. Dan

Ron Gusack
Expert
Expert
Posts: 684
Joined: Sat Dec 22, 2007 11:42 pm
Location: Maryland

Re: Drag race turbo 400 diagnosis

Post by Ron Gusack » Wed Oct 10, 2018 12:35 pm

Turned out to be the pin that hold the manual shift shaft to the case. That pin was a small finish nail the broke. I'd like to find a stronger pin but evidently a nail is what is commonly used. With no pin the shaft could walk out and allow the manual valve to disconnect and be free to go where ever it felt like going.
The things you see when you ain't got your gun!

6.50camaro
Member
Member
Posts: 112
Joined: Sun Jul 30, 2017 2:24 pm
Location: DeRidder, La

Re: Drag race turbo 400 diagnosis

Post by 6.50camaro » Wed Oct 10, 2018 1:50 pm

You should be able to find a roll pin to fit that. I believe that is what is used at the factory. Dan

Ron Gusack
Expert
Expert
Posts: 684
Joined: Sat Dec 22, 2007 11:42 pm
Location: Maryland

Re: Drag race turbo 400 diagnosis

Post by Ron Gusack » Wed Oct 10, 2018 7:47 pm

I don't know if I could get a roll pin in with the trans in the car. I'd feel better with a roll pin in it but I put a nail back in it.
The things you see when you ain't got your gun!

SupStk
Guru
Guru
Posts: 1392
Joined: Wed Jun 22, 2005 6:25 pm
Location: Box Elder, SD

Re: Drag race turbo 400 diagnosis

Post by SupStk » Wed Oct 10, 2018 9:41 pm

Yup TH400 used a pin that looked like a finish nail. First time I've heard of one breaking. Think I would just replace it.
Monty Frerichs
B&M Machine

Post Reply