Is This Cam Safe To Use?

General engine tech -- Drag Racing to Circle Track

Moderator: Team

User avatar
MadBill
Guru
Guru
Posts: 13709
Joined: Tue Nov 15, 2005 10:41 am
Location: The Great White North

Re: Is This Cam Safe To Use?

Post by MadBill » Thu Oct 04, 2018 10:57 pm

modok wrote:
Thu Oct 04, 2018 9:34 pm
Stone it and run it.
What could go wrong, it's the base circle
I'm with Glen. There's next to zero load on the base circle; what's going to happen? I'd eyeball the hell out of all the lobes (Magnaflux it if you like) and if no other flaws are revealed go for it.
Felix, qui potuit rerum cognscere causas.

Happy is he who can discover the cause of things.

sc2dave
Expert
Expert
Posts: 623
Joined: Tue May 24, 2005 10:45 pm
Location: Los Angeles, in The People's republic of Kalifornia

Re: Is This Cam Safe To Use?

Post by sc2dave » Thu Oct 04, 2018 11:02 pm

Cant you just coat it at some cam company? How about Cam King?

Newold1
Guru
Guru
Posts: 1614
Joined: Fri Apr 08, 2016 9:50 am

Re: Is This Cam Safe To Use?

Post by Newold1 » Fri Oct 05, 2018 4:15 pm

Some guys are dangerous and they really think they can get blood out of a turnip! I love turnips but I am not a vampire! :lol:
The Older I Get, The Dumber I Get :wink:

jfn2
New Member
New Member
Posts: 2
Joined: Tue Dec 02, 2014 11:18 am

Re: Is This Cam Safe To Use?

Post by jfn2 » Tue Oct 09, 2018 8:41 pm

I have a question. I picked up a used hyd performance cam for a cheap price because it looked very good lobe wise. Got it home and decided to check the lift and compare it to specs. All lobes checked out within a half thousands except # 6 cyl int. It was out by .003 low. Is this normal or should I throw this cam in the trash? It will be used in a street cruiser only.

n2xlr8n
Expert
Expert
Posts: 556
Joined: Tue Jun 28, 2005 9:01 pm
Location: Bama

Re: Is This Cam Safe To Use?

Post by n2xlr8n » Wed Oct 10, 2018 8:18 am

jfn2 wrote:
Tue Oct 09, 2018 8:41 pm
I have a question. I picked up a used hyd performance cam for a cheap price because it looked very good lobe wise. Got it home and decided to check the lift and compare it to specs. All lobes checked out within a half thousands except # 6 cyl int. It was out by .003 low. Is this normal or should I throw this cam in the trash? It will be used in a street cruiser only.
If careful inspection only revealed .003" out on one lobe- Yes, I'd use it in a street cruiser.
He who is in me is greater than he who is in the world.

Post Reply